Hoe kan ik updaten naar LibreOffice 6.2.1 in bijwerkbeheer?

Linux
Linux Mint
Zify
11 maart 2019 - 10:03

Ik krijg het niet voor elkaar om versie 6.073 naar de nieuwste versie Libre Office 6.2.1 te updaten in Linux Mint, hij komt ook niet tevoorschijn in bijwerkbeheer. Hoe doe ik dit?

Vraag is beantwoord

Reacties

Koala

Nog even afwachten denk ik. Wordt vanzelf t.z.t. aangeboden

Postbus

Je zult de update van LibreOffice moeten downloaden van de website; zie op GSS:
https://www.gratissoftwar...

Vergeet niet het help-bestand en het taalbestand ook binnen te halen; dat zijn aparte updates.

In de readme staan instructies, hoe te updaten; dit zal in een terminal moeten.

Koala

Ik heb me vergist, je kunt wachten tot je ons weegt. Voer op deze site de twee terminalopdrachten uit. De updates komen dan vanzelf via bijwerkbeheer.
Zelf ben ik bij versie 6.1.5.2. Versie 6.2 zal dan later aangeboden worden verwacht ik.

Koala

Deze website dus: https://www.omgubuntu.co....

Postbus

De rechtstreekse website voor Linux Mint is:
https://www.libreoffice.o...
en dus niets anders!

redactie

Linux Mint heeft een eigen softwarebeheerder waar automatisch de diverse pakketten bijgewerkt worden. LibreOffice wordt dus ook automatisch bijgewerkt door de software-beheerder van Mint, maar dat duurt soms even.

Je kunt echter ook, zoals Postbus al aangeeft, rechtstreeks van de site van LibreOffice de nieuwste versie downloaden. En kies dan het deb-bestand.

Dejan

In Linux Mint zit LibreOffice Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: nl-NL (en_US.UTF-8); Calc: group

Verder dan deze reeks zal hij NIET gaan in 19.1 of 19.0. Er bestaat een kans dat LibreOffice in een volgende puntversie van Linux Mint wordt 'bij'gewerkt, maar nogmaals, als je bij 19.0 of 19.1 blijft dan zal hij nooit meer worden bijgewerkt omdat LibreOffice 6.0 nu 'klaar' is.

Je kunt in Linux Mint 19.0/19.1 heel gemakkelijk een upgrade doen naar een andere versie van LibreOffice, maar doe dat exact hoe het nu beschreven gaat worden:

a. Indien geopend: sluit alle programma's van Libre Office af.

b. Verwijder eerst een eventueel aanwezige PPA voor een oudere versie van Libre Office, uit uw pakketbronnen. Op de volgende manier:

Menuknop - Beheer - Pakketbronnen
Druk op de knop PPA's en verwijder de bestaande PPA van Libre Office (indien aanwezig).

c. Open een terminalvenster.

d. Kopieer en plak de volgende opdrachtregel in de terminal:

sudo add-apt-repository ppa:libreoffice/libreoffice-6-2

Druk op Enter.

Druk op Enter en tik desgevraagd uw wachtwoord in. In Ubuntu blijft dit geheel onzichtbaar, u ziet zelfs geen sterretjes wanneer u het intikt, dat hoort zo. In Mint is dit veranderd: u ziet wel sterretjes. Druk opnieuw op Enter.

Druk wederom op Enter om toevoeging van de PPA te bevestigen.

e. Kopieer en plak nu onderstaande opdrachtregel in de terminal:

sudo apt-get update

Druk op Enter.

f. Start Bijwerkbeheer en ververs het. Installeer daarna de nieuwe pakketten die u krijgt aangeboden.

g. Start Libre Office. U zou nu versie 6.2.x moeten hebben.

BRON : https://makkelijkelinuxti...

Postbus

Een PPA wordt meestal als onveilig aangemerkt.

Dejan

Wat de meest simpele oplossing is, zo simpel dat ik er niet aan dacht, is om 'm gewoon als 'flatpak' te installeren. Je gaat naar softwaremanager, je kiest in de manager voor optie 'flatpak' en je zoekt op 'libreoffice'. Daar zit ALTIJD de nieuwste versie in en die wordt áltijd bijgewerkt ! Dus alleen als je dat niet vervelend vindt, op 'installeren' drukken en klaar. Verwijder echter nooit de libreoffice die oorspronkelijk bij het systeem hoort. Je kunt de pictogrammen wel verwijderen uit het menu zodat doublures niet ontstaan. ( anders zou je bijvoorbeeld een dubbele pictogram voor 'writer' hebben, één voor flatpak en één voor de 'oorspronkelijke' versie')

Maar dus NOOIT het originele pakket verwijderen, het systeem zakt dan als een pudding in elkaar.

Postbus

Hoe ingewikkeld kan iemand het toch maken...

Dejan

Het is helemaal niet ingewikkeld.

Zify

Bedankt voor het meedenken allemaal, lijkt mij het beste even af te wachten. Bij belangrijke brieven check ik deze dus eerst even op een andere (Microsoft) pc in ms office word.(ivm verspringen)

Koala

Kortom......hoe dan ook......erg onlogisch en onduidelijk in Linux voor de doorsnee gebruiker.

Dejan

Het is zeker wennen als je met Linux Mint begint en helaas zijn er geen handige handboeken ofzo. Maar als je naar deze site gaat: https://makkelijkelinuxti... worden bijna alle vragen beantwoord. Bovendien kan je deze site vrijwel blindelings vertrouwen omdat de auteur meer dan 30 jaar ervaring heeft. Linux lijkt ingewikkelder, maar vergeet ook niet dat juist die ( aan het begin schijnbare ) ingewikkeldheid bijdraagt aan een heel erg veilig en stabiel systeem. Maar dat het duidelijker mag voor de 'normale beginner' vind ik ook hoor. Aan het begin veel fouten gemaakt. Maar Linux is geen windows en op de desktop veel kleiner. Maar vandaar dat het handig is om hier tips te kunnen geven.

Postbus

Die link is inderdaad o.k.; ik kende hem al van https://sites.google.com/... . De tips heb ik als zeer waardevol ervaren, ook al in versie 18. Dus ook door mij van harte aanbevolen!

Reageren

Plain text

  • Toegelaten HTML-tags: <a> <em> <strong> <br> <br /> <i> <b> <p>
  • Regels en alinea's worden automatisch gesplitst.
  • Adressen van webpagina's en e-mailadressen worden automatisch naar links omgezet.
Controlevraag tegen spam
frankrij_